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Introduction

This training will guide you through the development of an operational humanitarian
vulnerability dashboard using the desktop tool Microsoft Power BlI.

Scenario

The protection cluster is focussing on identifying the most vulnerable districts within Yemen.
Such analysis will support operational teams in planning their humanitarian programming. To
give an overview of the most vulnerable areas, the protection cluster have asked you to
develop a dashboard highlighting the districts with the most people in need.

Data

The protection cluster have supplied you with a dataset:
e yemen_vulnerability.xlsx — an Excel file containing key metrics of vulnerability.

The dataset is separated by District with each row representing a District. Different geographic
levels are represented in the dataset:

e District — admin level 2 — lowest geographic level of data in this dataset.

e Gov — Governorate admin level 1. Each Governorate contains multiple districts.

¢ UNOCHA Operational Hub — UNOCHA geographic areas used to support operational
planning.

e PCODE - unique geographic code for district. PCODES ensure a consistency in
locating geographic areas. This is particularly useful when a geographic area can have
multiple spellings.

The dataset contains key vulnerability indicators:

Indicator

IDPs in District 2020 (HNO)

Resident 2020 (HNO)

Total Estimated Population 2020 (HNO)

Persons with Disabilities (Physical and Mental 15%)
# of separated and unaccompanied children

# of female headed households

Muhamasheen (Minority Group Presence)

% of non-functional schools

% of people with access to a regular income
Reduced coping strategies index

Poor to Borderline food consumptions scores (Jan 2019)
% of ind with access to markets

PIN Intercluster
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Notice that the data structure is consistent and clean. This flat data structure ensures data
quality is high and supports the use of tools such as Tableau or Power BI.

e Row 1 contains the name of each indicator.

e Every other row represents a district. There are no duplicate districts.

e [faindicator contains numerical data, the data does not contains text values.

e The data only contains one table and no graphs are present as these will be created in

file  Home Inset Draw  Pagelayout Formulas  Data  Review  View  Add-ins  Help 2 Share 3 Comments
< Cut A v =l — = zAuwSum v A
0 4 Calibri Jin VAR E== 9 Bwepten Number J| [E @ Fj &8 =% b= 7Y
Acopy v N =il v
Paste == === [z - Conditional Formatas Cell Insert Delete Format Sort& Find & Analyze
b B I Uiy GvAv | === =% EMegescener v B % 9 BN O Clear~ %
~ Format Painter Formatting ¥ Table ¥ Styles ¥ v c Filter v Select~ | Data
Clipboard [ Font ] Alignment [ Number [ Styles Cells Editing Analysis | Sensitivity ~
A25 M fx | YE1414 v
A 3 c o . & u | s x N
N s o e R e =
2 YEI209 |Aden 354 34359 | 34,713 | 5207 0
3 V201 |aden 615 36,368 37,017 5552 o
4 YE1208Aden ) 3199 5265 4% 3
5 Ye1203 [aden 306 20004 | 20210] 308 0
6 YELIL  Aden 18075 146,753 160872 24131 0
7 Ye1204|aden 49% 117,970 | 122,909 | 18,43 o
8 vEZoz Aden o0z a7991 | a3 | 7,390 o
9 VEL206|Aden 11 74,39 75,501 1,325 0
10 Y1207 |aden 98 20566 | 21,064 | 3160 0
1 YE1205|Aden 2,550 21,194 23,74 | 3562 o
12 YEL210 |Aden 9,884 31292 176 | 6175 0
13 Ye2404 |Aden 25,162 108,539 | 133,701 20055 o
14 YE2403 |aden 9461 171573 | 181,04 | 27,155 s
15 YE2406|Aden 3275 80484 | 83,759 | 12564 0

Ensuring data follows a consistent structure supports interoperability between different
datasets and allows complex analysis to be developed in a timely, consistent and accurate
manner. Similarly, the use of PCODES supports accurate geographic mapping of the data.

For this training you will only be using a few vulnerability metrics. Further details of the data
can be found in Appendix 1.

Power Bl installation

To install Power Bl Desktop, go to https://powerbi.microsoft.com/en-us/downloads/ and
download Microsoft Power Bl Desktop.

"2

Microsoft Power Bl Desktop

With the Power Bl Desktop you can visually explore your
data through a free-form drag-and-drop canvas, a broad
range of modern data visualizations, and an easy-to-use
report authoring experience.

Download »

Advanced download options >

Download is free. If you have an Office 365 License you will be able to publish dashboard
online.


https://powerbi.microsoft.com/en-us/downloads/

Exercise instructions

1.
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Open Power Bl desktop.
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2. Click Get data -> Excel

-> Connect.
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3. Locate the yemen_vulnerability xIsx file and click Open.
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4. Once opened, the Navigator will show the tabs available in the Excel spreadsheet.
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5. The data will then take a few seconds to load.

Steve Penson

Untitled - Power BI Dx

File Home Insert Modeling View Help External Tools
He b B i [A] df
@& la & [® © & # Al 07
Get  Excel PowerBl SQL Enter Dataverse Recent Transform New  Text More
datav datasets Server data sources v datav visual box visuals v
Clipboard Data Queries Insert Calculations Sensitivity Share A

] A There are pending changes in your queries that haven't been applied. Apply changes Discard changes X \sicalizations >  Fields

i} 4 P search
n
E =
F
@
Add " ’ =
Once loaded, you Load Values
Add data fields here
ﬁ Creating connection in model. Drill through
Cross-report
Concel
Import data from Excel Import data from S Ciie,
Keep allfilters
Get data from another source —
on—@
Add drill-through fields here
Page 1 +*
Page 10f 1
” = R 16:44

06/06/2021 17

L Type here to search

6. Once loaded, the Excel spreadsheet data will be available in the Fields panel on the
right hand side. This contains available column names we can use for analysis.

Steve Penson

Untitled - Power BI D

File Home Insert Modeling View Help External Tools
He b PLAdAdg B 4 @
@ [a & [B o B Lo L} 4 7
Get Excel PowerBl SQL Enter Dataverse Recent  Transform Refresh ~ New Text More New  Quick Publish
datav datasets Server data sourcesv  datav visual box visualsv  measure measure
Clipboard Data Queries. Insert Calculations Sensitivity Share. ~
el < Visualizations > Fields >
= BB ENEB [Osarmn
- S Ednbbe
3 = V|
FHNTEEOO®E yemen_vulnerability
@ e % BEBE 3. #of female headed households
B Y #of separated and unaccompanied children
Build visuals with your data Y % of ind with access to markets
. . % of non-ft ional school:
Select or drag fields from the Fields pane onto the report canvas. X % of non-functional schools
Y % of people with access to a regular income
Vs District
v Add data fields here District Peode
W i Gov
Drill through
3 IDPs in District 2020 (HNO)
Cross-report Muhamasheen (Minority Group Presence)

Persons with Disabilities (Physical and Mental 15%)
¥:

off O—

3 PIN Intercluster
Keep all filters
3 Poor to Borderline food consumptions scores (Jan 2019)
on—@ T Reduced coping strategies index
> Resident 2020 (HNO)

[J Y. Total Estimated Population 2020 (HNO)

Add drill-through fields here

UNOCHA Operational Hub

Page 1 +*

Page 10f 1



7.

ACAPS HAP Power BI Training Guide

8.

acaps®

In the Fields panel click ‘Gov'. A new table will be created in the dashboard window.
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added to the table.

In the Fields panel click ‘PIN Intercluster’. The number of PIN per governorate will be
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9. Click on the table and drag down to show the whole table.
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10. Once the table is selected, under the Visualisation panel click on the Clustered Bar

charticon E
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11. On the Visualisations panel select the Map icon e . A new empty panel will be
created in the dashboard.
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12. From the Fields panel, drag and drop the ‘latitude’ field to Latitude and the ‘longitude’
field to Longitude. Points representing each district should now be visible on the map.
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13. From the Fields panel, drag and drop the ‘PIN Intercluster’ field to Size. The district
points will now be sized based on the number of people in need within the district.
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14. With the map selected, click the Format icon T . Under the bubbles option, it is
possible to readjust the size of the bubbles to make the map clearer.
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15. To adjust the bar graph from Governorate to District, click on the graph and drag and
drop the District field into Axis section of the Visualisations panel. The graph will now
show PIN per district rather than by governorate.
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16. To be able to filter the data by governorate and district, click on the dashboard window

away from the graph and map and select the Slicer icon |—=|? A blank slicer panel will
appear on the dashboard window.
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17. With the Slicer panel selected, from the Fields panel click Gov.
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18. Click District. Both governorate and district will now be available in the slicer, giving the
user to ‘drill-down’ the select the geography.
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19. To the top right of the Slicer box, click the dropdown and select Dropdown option —
this will change the Slicer from a filter list to a dropdown filter.
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20. To add a title to your dashboard, under the Insert menu click Text box. Draw a text box
within the dashboard window.
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21. Into the text box type a title such as "Yemen People in Need Summary — January
2027
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22. To add an logo to your dashboard, under the Insert menu click Image. Draw a Image
box within the dashboard window.
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23. Locate the image location and click Open
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24. Rearrange the dashboard objects as required.
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25. You can use the slicer, points on the map or graph to filter the dashboard.
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26. The dashboard is now complete. It is now possible to analyse and filter PIN numbers
by district using both the map and the graph.
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27. To save your dashboard, click File -> Save As and save in a suitable location.
Power Bl files are saved as .pbix files.
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Additional exercises

Now you have completed your first operational dashboard, attempt to answer the following
questions by adding additional functionality and analysis to your dashboard:

1. Using fields ‘IDPs in District 2020 (HNO)" and ‘Total Estimated Population 2020 (HNO)',
identify which district has the highest number of IDPs as a percentage of population?
Note: Total Estimated Population = IDPs in District + Resident. Any Districts where this
does not add up suggests incorrect data and should be flagged or removed from the
analysis

2. Using fields ‘% of people with access to a regular income’ and ‘Total Estimated
Population 2020 (HNOY)', calculate the 5 top districts which have the highest estimated
population without access to a regular income. What might be the limitations with this
methodology?

3. Using the ‘Muhamasheen (Minority Group Presence)’ field, create a table, map and
filter visualising which districts have Muhamasheen present and which districts do
not.

Further training resources

Further training resources can be found at https://powerbi.microsoft.com/en-us/learning/.

This work is licensed under a Creative Commons Attribution-NonCommercial 4.0 International License.
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Appendix 1 - Data review

ACAPS HAP Power BI Trainin acaps @

Field Description

District Pcode

PCODES are unique admin area codes use to define a geographical area such as an
governorate or district boundary.

Using PCODES helps to ensure consistency between datasets as using a unique code mitigates
against issues of different place names spellings and ensures datasets can be joined easily.
PCODES are assigned by UNOCHA and are part of the Common Operational Datasets.

UNOCHA Operational Hub

Name of the UNOCHA Operational Hub used to plan OCHA humanitarian programmes.

Gov

Governorate name.

District

District name.

IDPs in District 2020 (HNO)

Number of internally displaced people (IDPs) within district as taken from the 2020
Humanitarian Needs Overview.

Resident 2020 (HNO)

Number of non-IDP residents within district as taken from the 2020 Humanitarian Needs
Overview.

Total Estimated Population 2020 (HNO)

Total number of IDPs and residents within district as taken from the 2020 Humanitarian Needs
Overview.

Persons with Disabilities (Physical and Mental 15%)

Approimation of the number of persons with disabilities by district.

# of separated and unaccompanied children

Number of separated and unaccompanied children by district.

# of female headed households

Number of female headed households by district.

Muhamasheen (Minority Group Presence)

Whether the district contains vulnerable Muhamasheen communities.

% of non-functional schools

Percentage of non-functional schools within the district.

% of people with access to a regular income

Percentage of people with access to a regular income.

Reduced coping strategies index

The Reduced Coping Strategies Index (RCSI) is a proxy indicator of household food insecurity.
The higher the rCSI score, the worse the food insecurity as people are deemed to be using more
negative coping strategies.

Poor to Borderline food consumptions scores (Jan 2019)

Number of people deemed to be have poor or borderline food consumption as of January 2019
by district.

% of ind with access to markets

Percentage of individuals with access to market by district.

PIN Intercluster

Number of intercluster people in need by district.

longitude

Geographical longitude of the centre point of the district.

latitude

Geographical latitude of the centre point of the district.
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